Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Firmware 5.2 stable


Recommended Posts

  • Replies 329
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi everyone,     Thank you for all the time and energy you invest in sharing your messages here, trying to share your perspective with others. I like to think that this all comes from the sa

Since we only ever fill the threads with complaints and blames about bugs and errors, the positive should also be highlighted.   Bringing the firmware from UM3 to the same code base was cert

Hi everyone,   I'm also from Ultimaker, also not a firmware engineer but I've been busy trying to collect more information about this uncomfortable situation. If you have read through the pa

Posted Images

Posted · Ultimaker Firmware 5.2 stable
35 minutes ago, ScanHD said:

i notice that the update download is now no longer available by USB.... wifi only?

 

shall i stop trying by usb then?

 

thanks

Yeah, just clicked the link in the first post and it does not have any download options for USB.

 

I find this to be a bit surprising as it assumes that everybody is on unlimited bandwidth.

 

I am on a metered connection for now and this prevents me from updating my systems. So, what is the difference between downloading the software to USB or direclty to the machine? Well, To use the machine itself and wifi, increases 'chatter' between machine and whatever is connected on the other end.

 

My basic procedure is this: If I am checking email or reading articles, I engage the wifi on the computer only. When not doing so, I disengage the wifi.

 

How do I know that there is chatter on the wifi when not using a browser? Well, I can see the activity happen on the wifi indicator on the wifi unit. Things are always pinging out, checking for this and that. It adds up. I do not stream movies. I do not watch TV on the internet. But I still struggle to stay under 50GB per month because of all the crap that is sent back and forth.

 

So, my question is whether I will be able to upgrade my machine operating systems via USB or not? If not, then I have to re-evaluate a few things because these machines are stuck in this time warp of non update and I do not think that is a good thing. I can still print, but have to put up with firmware that has a lot of issues. And, that limits the fun.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    10 minutes ago, kmanstudios said:

    Yeah, just clicked the link in the first post and it does not have any download options for USB.

     

    I find this to be a bit surprising as it assumes that everybody is on unlimited bandwidth.

     

    I am on a metered connection for now and this prevents me from updating my systems. So, what is the difference between downloading the software to USB or direclty to the machine? Well, To use the machine itself and wifi, increases 'chatter' between machine and whatever is connected on the other end.

     

    My basic procedure is this: If I am checking email or reading articles, I engage the wifi on the computer only. When not doing so, I disengage the wifi.

     

    How do I know that there is chatter on the wifi when not using a browser? Well, I can see the activity happen on the wifi indicator on the wifi unit. Things are always pinging out, checking for this and that. It adds up. I do not stream movies. I do not watch TV on the internet. But I still struggle to stay under 50GB per month because of all the crap that is sent back and forth.

     

    So, my question is whether I will be able to upgrade my machine operating systems via USB or not? If not, then I have to re-evaluate a few things because these machines are stuck in this time warp of non update and I do not think that is a good thing. I can still print, but have to put up with firmware that has a lot of issues. And, that limits the fun.

     

    The downloadable update is only temporarily not available. Online update is still possible. 

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    4 hours ago, rsiudak said:

     

    The downloadable update is only temporarily not available. Online update is still possible. 

    Yeah, still not a good thing for those without the wifi to do so, yes? And, not saying why it is unavailable is kinda not helpful either.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    My Ultimaker 3 prompted me to upgrade firmware this week with which I faithfully complied.  Since upgrading I have been plagued with numerous intermittent issues that have rendered my UM3 unusable. Is it possible to roll back this firmware to restore functionality?  A partial list of issues observed after upgrading to UM3 V5.2 and Cura 4.0 follows...  

    Can't print directly to UM3 over network any longer despite seeing printer in Cura. Must save gcode to USB and print that way.

    Cura won't discover UM3 automatically on network, must add manually by IP.

    UM3 keeps prompting me to change materials to the ones that are already loaded.

    UM3 keeps rebooting at random times almost like power has been cut for several seconds and then print fails.  This occurs so frequently now that  I am unable to use  my UM3.  

    Reboot of UM3 is very erratic now with the frame light flickering and the machine making clicking noises it never made before.

    UM3 attempts to move material without first heating orient cores.

    Menu structure and navigation are erratic and confusing with no way to cancel or abort many options and messages that are in progress and don't apply to what I am trying to do.

    Please help!

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    My WiFi isn't working... I can not activate the wifi on my S5 anymore ...

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    Hi All,

     

    We've got reports from users trying to update their unconnected printers using USB that they could not initiate the update. This is due to a failing consistency check, prohibiting the update when the printer can not get the correct date over a network connection. To prevent confusion, we've removed the download links from the update page. We will reinstate the links soon.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    11 minutes ago, WesleyE said:

    Hi All,

     

    We've got reports from users trying to update their unconnected printers using USB that they could not initiate the update. This is due to a failing consistency check, prohibiting the update when the printer can not get the correct date over a network connection. To prevent confusion, we've removed the download links from the update page. We will reinstate the links soon.

    👍

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    @N9ssham - yes it's possible to go back to older versions.  There are two methods - the "unbricking" method and the normal method. 

     

    edit:

    The normal method doesn't work when going from 5.2 to older versions.  So you have to use the "unbricking" method which involves removing covers and such and should not be done if you don't know anything about how to prevent static electricty from causing serious damage or if you are just good at breaking things.

     

    Procedure is here:

     


     

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    Nobody knows where the loss of WIFI (gray button) since the update of my UM5? does an update correct the problem? I am very disappointed ?

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    WIFI works for most people but other's have complained.  I guess try power cycling and also wifi setup.  Do you have firmware 5.2.X?  Many people say to "reset cura connect" but I don't know what that means or how to do that but it fixes many problems supposedly.

     

    I ask about firmware version because you may right now have the "stepping stone" version which is meant to do nothing but update you to 5.2.X.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    12 minutes ago, gr5 said:

    Many people say to "reset cura connect" but I don't know what that means or how to do that but it fixes many problems supposedly.

     

    It's a menu option in the network ? menu or where you find the factory reset, don't remember now exactly, and it resets only the cura connect part of the printer, which solves a lot of problems like camera not working, cura cannot find printer, and some other things.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    I already have to reset Cura connect from the menu of my S5, however the WIFI still does not work, the bonton is grayed out ... I also tried to fully reinstall the printer, it has rioen changed ... Yes I am in 5.2.8 20190320 ...

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    On 3/22/2019 at 1:55 AM, kevin-osborn said:

    My Ultimaker 3 just asked me to upgrade the firmware and I did.

    5.2.8.20190320

    Since upgrading, it levels the bed, but then lowers the bed and prints in the air. I tried a factory reset, manual bed levelling, and upgraded Cura to the 4.0 download, all the same.

     

    Help! my UM3 is worthless now!

    I am getting the same problem, i think it must be down to using a non zero z-offset in the Bed Adhesion section, doesn't seem to matter if its -ve or +ve just before printing starts the bed drops down approx 1/2 inch, and nozzle prints in mid air.

     

    I see a later reply suggesting removing Z92 -0.3  how are you doing this, i am using Curas Print Over Network, so dont get to

    view the Gcode before sending. Did you Save to file and then edit it.

     

    Any answer on how to downgrade, this is going to be a real problem?

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    Downgrading can be done.  See "unbricking" 2 of my posts above.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    5 hours ago, itretail said:

    I am getting the same problem, i think it must be down to using a non zero z-offset in the Bed Adhesion section, doesn't seem to matter if its -ve or +ve just before printing starts the bed drops down approx 1/2 inch, and nozzle prints in mid air.

     

    I see a later reply suggesting removing Z92 -0.3  how are you doing this, i am using Curas Print Over Network, so dont get to

    view the Gcode before sending. Did you Save to file and then edit it.

     

    Any answer on how to downgrade, this is going to be a real problem?

    I solved the problem by deleting my entire install of Cura and starting from scratch.

    I verified it initially by hand editing the gcode, but with a fresh install of cura, I can print via network etc.

    Note: you do have to delete all the settings as Cura faithfully tries to copy previous settings from older versions.

    On the mac it's in ~/Library/Application Support/Cura/<various versions>

    google cura settings locations if you are on another platform.

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    5 hours ago, kevin-osborn said:

    Note: you do have to delete all the settings as Cura faithfully tries to copy previous settings from older versions.

     

    Quick tip: If instead of removing the folder named "4.0" you make the folder empty (so remove the files inside the folder, but leave the folder there), you will get a "clean" Cura 4.0 but leave your older Cura configurations in place for older versions of Cura to use.

    • Like 2
    Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    Hey all,

     

    I did have the similar floating print issue that @kevin-osborn had, but had to clear out Cura like he found out to fix it.  So first off, thanks @kevin-osborn and everyone who contributed - it was driving me crazy for a bit especially since I was printing fine last night.

     

    I do have a second issue, wondering if anyone else has it.  After a print either finishes or I cancel it, my printer is no longer found by Cura and I have to do a power cycle of the ultimaker and then go back into cura to connect to it.  Does anyone else have this issue and/or does anyone have any suggestions?

     

    Thanks,
    Bobby

     

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    For those with serious problems (like not working WiFi) after the update to 5.2.8 I would suggest a factory reset. There has been an UM3 firmware upgrade in the past (I think it was the one which introduced Cura Connect) which also required a factory reset on some machines.

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    39 minutes ago, Dim3nsioneer said:

    For those with serious problems (like not working WiFi) after the update to 5.2.8 I would suggest a factory reset. There has been an UM3 firmware upgrade in the past (I think it was the one which introduced Cura Connect) which also required a factory reset on some machines.

     

    For my part I have already tried to reset my S5, but this has not worked anything ... the Wifi still does not work ...

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    19 minutes ago, WesleySAV17 said:

     

    For my part I have already tried to reset my S5, but this has not worked anything ... the Wifi still does not work ...

     

    Then I suggest you get in contact with your reseller and send him the logs.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable
    On 3/22/2019 at 6:48 PM, Smithy said:

     

    That's bad, for me, the noise was gone as soon as I turned the wheel and never came back. But I have to say, I haven't printed yet, so maybe it will come back with some action.

     

    Regarding the annoying noise on the UM3, I am pretty sure it comes from the display. Because I noticed yesterday again the noise, just turning on the wheel didn't help, but jump in another submenu helped - noise gone. Immediately after return to the main menu and the noise comes again. So for me, this high-frequency buzzing noise is currently only there when the printer is in its main menu. As soon as I jump in the Material or System submenu it is gone.

     

    Ofc due to the high-frequency you can only hear it if you are in a silent area, but for me, this sound is very annoying, so good that there is a "workaround" but I think this should be fixed. Was definitely not there before the FW upgrade.

  • Link to post
    Share on other sites
    Posted · Ultimaker Firmware 5.2 stable

    I really hope that Ultimaker will release very quickly a firmware that will correct all that is problem ...

    I'm not about to update my S5 .... really disappointed ...

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...